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CE VRE M SA  FACEM  

Prin acest tutorial vrem sa facem o introducere in programarea cu frameworkul .NET 3.5 . Vom realiza o aplicatie de 

tinerea evidentelor activelor angajatilor unei intreprinderi. Intentia este sa  o trecem , realizind diverse 

feature(raportare, integrare Active Directory,etc) cam prin tot ceea ce inseamna programarea in .NET : de la 

WebSite la WindowsForms, trecind prin WebService, etc.  

Acesta nu va fi un tutorial de programare- nu vom incepe cu ceea ce inseamna variabile, i++ si alte lucruri de genul 

acesta. Pentru aceasta va rog consultati, de ex., 

http://www.microsoft.com/romania/educatie/cursnet/default.mspx (aveti varianta pentru elevi si pentru 

profesori) 

Vom realiza acest lucru cu editiile Visual Studio Express ( http://www.microsoft.com/express) raminind ca, pe 

masura ce se poate, sa aratam diferentele intre ele si celelalte. 

Sa trecem la treaba! 

Lecturi recomandate: 

Being a programmer, http://www.codeproject.com/KB/work/BeingAProgrammer.aspx 

How to be a Programmer: A Short, Comprehensive, and Personal Summary , 

http://samizdat.mines.edu/howto/HowToBeAProgrammer.html  

91 Guaranteed Ways to Become an Even Greater Developer, http://effectize.com/become-

coolest-programmer 

 

 

 

PRIMUL  PAS : INS TALA REA  SOFT WARE-UL UI FREE  

 

Acest pas se efectuează o singura date pe PC. Este vorba despre instalarea server-ului de Web , precum si a Visual 

Studio Express ca si unealta de dezvoltare. Este cel mai lung pas, dar, precum am spus, se efectuează o singura 

data. 

 

Să începem: ai Windows (XP, de preferinţă) si ne asiguram ca ai server-ul de Web (Internet Information Services – 

IIS de acum înainte) pe maşină .Pentru aceasta te duci in “Control panel” => “Administrative Tools” si verificaţi ca 

http://www.microsoft.com/romania/educatie/cursnet/default.mspx
http://www.microsoft.com/express/
http://www.microsoft.com/express
http://www.codeproject.com/KB/work/BeingAProgrammer.aspx
http://www.codeproject.com/KB/work/BeingAProgrammer.aspx
http://samizdat.mines.edu/howto/HowToBeAProgrammer.html
http://effectize.com/become-coolest-programmer
http://effectize.com/become-coolest-programmer
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există. 

 

 

 Daca nu exista, mergeţi înapoi la “Control Panel”, apăsaţi pe “Add or Remove programs” si apăsaţi pe 

“Add/Remove Windows Components”. Bifaţi IIS ca in imagine si daţi “Next”( asiguraţi-vă ca aveţi CD-ul de instalare 

Windows prin apropiere) 
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Bun – acum o sa instalam VS 2008 Express. Acesta este free si îl puteţi descărca  de la adresa 

http://www.microsoft.com/express/download/ . Acolo , jos de tot, gasiţi o imagine ISO 

(VS2008ExpressWithSP1ENUX1504728.iso) pe care o puteti downloada . O puteţi vedea cu ISObuster, Daemon 

Tools or Virtual CloneDrive ( căutaţi-le pe google pentru linkuri de download) sau cu un program făcut de MS, 

Virtual CD-ROM Control Panel for Windows XP care poate fi downloadat de la adresa: 

http://download.microsoft.com/download/7/b/6/7b6abd84-7841-4978-96f5-

bd58df02efa2/winxpvirtualcdcontrolpanel_21.exe 

Pentru o adresa mai scurta, incercati http://tinyurl.com/winxpvirtualcdcontrolpanel 

Pentru instalare incarcati CD-ul si , daca aveti autorun, va va aparea imaginea urmatoare: 

http://www.microsoft.com/express/download/
http://tinyurl.com/winxpvirtualcdcontrolpanel
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Vom instala C# si WebDeveloper. Cei care vor o varianta in VB.NET , exista un traducator intre s intaxe la adresa 

http://www.carlosag.net/Tools/CodeTranslator/ si altul la http://www.developerfusion.com/tools/convert/csharp-

to-vb/ 

Cind instalati , deselectati SQL Server – il vom instala mai tirziu 

http://www.carlosag.net/Tools/CodeTranslator/
http://www.developerfusion.com/tools/convert/csharp-to-vb/
http://www.developerfusion.com/tools/convert/csharp-to-vb/
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Daca ati terminat de instalat si C# si WebDeveloper,  urmatorul pas este sa instalati Powershell de la adresa 

http://www.microsoft.com/powershell. Spre deosebire  de VS sau SQL Server, acesta cere Microsoft Genuine 

validation . 

Ne instalam si Windows Installer 4.5 de la http://www.microsoft.com/downloadS/details.aspx?familyid=5A58B56F-

60B6-4412-95B9-54D056D6F9F4&displaylang=en ( sau http://tinyurl.com/wininst4-5 ) . Atentie sa luati pe 

specificul sistemului dumneavoastra( de ex., pentru Windows XP pe 32, luati WindowsXP-KB942288-v3-x86.exe) 

 

Acum putem instala SQL Server Express Edition with Advanced Services SP2 de la adresa 

http://www.microsoft.com/express/sql/download/default.aspx . Luati SQL Server 2008 Express with Advanced 

Services  - o sa facem si rapoarte in Sql Reporting si multe altele.Va duceti pe “planning” si alegeti “system 

configuration checker”. Daca ati trecut toate, atunci putem da pe “installation”-“new sql server stand alone ….”. 

OK-dupa o suita de”Next” ajungeti la “Feature Delection” – dati “Select all”. 

La “database engine” dati o parola pentru sa si nu uitati sa apasati “add current user” 

http://www.microsoft.com/powershell
http://www.microsoft.com/downloadS/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F9F4&displaylang=en
http://www.microsoft.com/downloadS/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F9F4&displaylang=en
http://tinyurl.com/wininst4-5
http://www.microsoft.com/express/sql/download/default.aspx
http://go.microsoft.com/?linkid=9394724
http://go.microsoft.com/?linkid=9394724
http://go.microsoft.com/?linkid=9394724
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De asemenea nu uitati de “Filestream”, care rezolva problema veche:”sa pastrez documentele in BD sau doar un 

link catre calea lor?” 
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Acum ramine doar “Next”…si sa restartati PC-ul  - de siguranta si ca sa porneasca serviciile automat, nu sa le porniti 

din control panel=>services.msc 

 

Acum, despre inregistrare : daca va inregistrati download-urile , atunci primiti citeva chestii free –intre care mie mi-

au placut imaginile . Vedeti http://www.microsoft.com/express/registration/ 

In cele din urma mai avem nevoie, pentru Silverlight , de downloadat Microsoft® Silverlight™ Tools for Visual Studio 

2008 SP1 http://www.microsoft.com/downloads/details.aspx?familyid=C22D6A7B-546F-4407-8EF6-

D60C8EE221ED&displaylang=en 

De asemenea puteti lua si Sample Source Code for Silverlight 2 Runtime and SDK Controls, 

http://www.microsoft.com/downloads/details.aspx?FamilyID=EB83ED4C-AC85-4DE9-8395-

285628EE2254&displaylang=en 

 

Data viitoare vom face o mica aplicatie ca sa accesam rapid SQL Server si sa vedem ca functioneaza 

Lecturi recomandate: 

 Dan Fernandez , Top 15 Things to love about Visual Studio 2008 Express  - 

http://blogs.msdn.com/danielfe/archive/2007/11/19/top-15-things-to-love-about-visual-studio-2008-express.aspx 

 Petzold , .NET Book Zero - http://www.charlespetzold.com/dotnet/ 

http://www.microsoft.com/express/registration/
http://www.microsoft.com/downloads/details.aspx?familyid=C22D6A7B-546F-4407-8EF6-D60C8EE221ED&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=C22D6A7B-546F-4407-8EF6-D60C8EE221ED&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=EB83ED4C-AC85-4DE9-8395-285628EE2254&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=EB83ED4C-AC85-4DE9-8395-285628EE2254&displaylang=en
http://blogs.msdn.com/danielfe/archive/2007/11/19/top-15-things-to-love-about-visual-studio-2008-express.aspx
http://www.charlespetzold.com/dotnet/
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 C# yellow book , http://www.robmiles.com/c-yellow-

book/Rob%20Miles%20CSharp%20Yellow%20Book%202008.pdf 

 

 

  

 

VERI FICA RE I NSTAL ARE   

 

Ca sa verificam aplicatia, vom creea o noua baza de date si ne vom conecta la o tabela sa obtinem datele.  

 

Pornim Sql Server Management Studio ( Start=> Programs => Microsoft SQL Server 2008 => SQL Server 

Management Studio ) si ne conectam la .\SqlExpress ( numele instantei este in Control Panel=> Administrative 

Tools => services => Sql Server. Vedeti Path to executable . Daca se termina in "<cale>\sqlservr.exe" –s<Nume>, 

atunci numele sub care va conectati este .\<Nume> . Daca nu, va puteti conecta la . ) 

 

Ok, acum dati click dreapta Databases, NewDatabase si introduceti “testAndrei”. 

Apasati apoi OK 

Expandeaza apoi “Databases” apasind pe + ( daca e deja expandat, click pe Databases si apoi F5) 

Expandeaza “testAndrei”, click dreapta pe table, “New Table”. La “column name” pune Test si apasa “enter” . 

Apasa CTRL+S si introdu “TestTable” 

Expandeaza “Tables” apasind pe + ( daca e deja expandat, click pe Tables si apoi F5) 

Click dreapta si “Edit 200 rows” . In casuta puneti “Andrei” si apasa “enter” 

Acum inchide tot.  

 

Felicitari, ai creat prima ta baza de date, cu prima tabela ! 

O vom acces acum prin C#. 

Deschide Microsoft Visual C# 2008 Express Edition (Start=> Programs => Microsoft Visual C# 2008 Express Edition) . 

File=> New project  si alegeti “Console Application” 

Introduceti urmatorul text: 

http://www.robmiles.com/c-yellow-book/Rob%20Miles%20CSharp%20Yellow%20Book%202008.pdf
http://www.robmiles.com/c-yellow-book/Rob%20Miles%20CSharp%20Yellow%20Book%202008.pdf
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using System; 

using System.Collections.Generic; 

using System.Linq; 

using System.Text; 

using System.Data; 

using System.Data.SqlClient; 

namespace ConsoleApplication1 

{ 

    class Program 

    { 

        static void Main(string[] args) 

        { 

            using (SqlConnection sc = new SqlConnection()) 

            { 

                sc.ConnectionString = 

@"Server=.\SqlExp2008;Database=testAndrei;Trusted_Connection=True;"; 

                try 

                { 

                    sc.Open(); 

                } 

                catch (SqlException ex) 

                { 

                    Console.WriteLine(" Eroare conexiune:" + ex.Message); 

                    return; 

                } 

                using (SqlCommand sco = new SqlCommand()) 

                { 

                    sco.CommandType = CommandType.Text; 
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                    sco.CommandText = "select top 1 Test from TestTable"; 

                    sco.Connection = sc; 

                    string text = sco.ExecuteScalar().ToString(); 

                    Console.WriteLine(" am gasit in BD " + text); 

                } 

            } 

 

        } 

    } 

} 

 

Dupa cite observati, am interceptat eroare de conexiune cu try/catch – daca SQL Server nu e pornit sau exista o alta 

problema, da o eroare custom. 

 

Apasati CTRL+Shift+B si, daca v-au dat erori, rezolvati-le sau scrieti-mi. 

Daca nu, CTRL+F5 si , daca totul e OK, va va aparea : 

 

am gasit in BD andrei 

Press any key to continue . . . 

 

Daca nu, puteti sa imi scrieti – dar dati-mi, va rog, descrierea erorii … 

 

 

 

 

Ca bonus vom accesa SQL Server prin Powershell . Deschideti din nou Sql Server Management Studio , expandati 

Databases si click dreapta pe “TestAndrei”. Acolo aveti “Start PowerShell” . Sa zicem ca vrem sa obtinem o lista cu 

toate tabelele din BD TestAndrei( deocamdata una singura, dar orisicit …) . Nimic mai simplu : Dati “cd Tables” , 

<enter> si apoi “dir” 
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Daca am vrea sa exportam lista intr-un format, am putea da urmatoarea comanda 

DIR | Sort-Object -Property Schema,Name | Format-Table schema, name –AutoSize 

Daca am vrea sa le si exportam, de exemplu in CSV, vom utilize 

DIR | Sort-Object -Property Schema,Name | Select-Object schema, name | export-csv c:\tables.csv 

Rezultatul ar trebui sa fie urmatorul :  

 

#TYPE System.Management.Automation.PSCustomObject 

Schema,Name 

dbo,TestTable 

 

Data viitoare vom trece aceasta aplicatie minimala prin in Windows Forms, WPF, ASP.NET ca sa dau o idée despre 

ce ne asteapta de la acest tutorial. 

 

Sursa o gasiti si la  

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/testBD.zip 

Backupul bazei de date  

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/testandrei.zip 

Ca sa refaceti aplicatia : 

Extrageti continutul zip-urilor. 

Pentru a reface Baza de date urmariti pasii: 

Porniti Sql Server Management Studio ( Start=> Programs => Microsoft SQL Server 2008 => SQL Server 

Management Studio ) si ne conectam la .\SqlExpress ( numele instantei este in Control Panel=> Administrative 

Tools => services => Sql Server. Vedeti Path to executable . Daca se termina in "<cale>\sqlservr.exe" –s<Nume>, 

atunci numele sub care va conectati este .\<Nume> . Daca nu, va puteti conecta la . ) 

 

Ok, acum dati click dreapta Databases=> Restore Database , puneti la numele bazei de date ”TestAndrei” –sper sa 

nu folositi acest nume ( daca da, dati, va rog, altul! ) . Selectati apoi “From device” apasati cele 3 puncte si selectati 

fisierul .bak. 

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/testBD.zip
http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/testandrei.zip
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Verificati, de asemenea, la “options” ce cale aveti scrisa pentru locatia fisierelor. 

 

Lecturi Recomandate: 

 

 PowerShell tutorial : https://blogs.technet.com/chitpro-de/archive/2007/05/10/english-version-of-

windows-powershell-course-book-available-for-download.aspx  

 ConnectionStrings : http://www.connectionstrings.com/ 

  

 

APLICATII  MICI  DE T EST  

https://blogs.technet.com/chitpro-de/archive/2007/05/10/english-version-of-windows-powershell-course-book-available-for-download.aspx
https://blogs.technet.com/chitpro-de/archive/2007/05/10/english-version-of-windows-powershell-course-book-available-for-download.aspx
http://www.connectionstrings.com/
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Acum vom trece aplicatia minimala de consola in mai multe outputuri : Windows Forms, Asp.NET, WPF 

Vom transforma aceasta aplicatie intr-una de Windows Forms 

Click dreapta pe solutie, Add=> New Project, Windows Forms Application 

 

 

Dublu click pe form1, luam un buton din Toolbox , dublu click pe el, si apare evenimentul de click 
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Copiem exemplu de la aplicatia ConsoleApplication1, modificand Console.Write in MessageBox  

In figura alaturata se vede ca nu aplicatia nu stie cine este SqlConnection. Dar, imediat in 
stinga, exista un icon mic -daca dati click pe el, o sa vedeti ca stie  - 

alegeti "using" 
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Alegeti "set as startup project" 
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CTRL+F5 si apasati pe "buton1" - ar trebui sa va apara 

 

 

 

 

Ce am observat ? Ca am scris de 2 ori acelasi cod. Daca am avea de modificat, nu ar fi cam greu in 

aceasta aplicatie -dar pentru o aplicatie mare am putea intimpina probleme. Ar fi bine daca acest cod s-ar 
tine undeva , intr-o locatie comuna - ceea ce in Windows numim dll. 

OK - sa adaugam un dll - click dreapta pe Solution, Add=>New Project , Class Library 

A aparut "Class1" si adaugam codul de pe Consola, modificat putin - nu mai interceptam SqlException -ca 

nu am stii ce sa intoarcem ( de fapt, ar trebui sa ne facem clasa noastra de exceptii  - dar despre asta mai 
tirziu) - si intoarcem chiar ce gasim in BD: 
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 public string MessageFromBD() 

        { 

            using (SqlConnection sc = new SqlConnection()) 

            { 

                sc.ConnectionString = 

@"Server=.\SqlExpress;Database=testAndrei;Trusted_Connection=True;"; 

                sc.Open(); 

                using (SqlCommand sco = new SqlCommand()) 

                { 

                    sco.CommandType = CommandType.Text; 

                    sco.CommandText = "select top 1 Test from TestTable"; 

                    sco.Connection = sc; 

                    string text = sco.ExecuteScalar().ToString(); 

                    return text; 

                } 

            } 

 

        } 

 

 

Bun - acum sa chemam acest mesaj si in consola, si in Windows Forms.La amindoua dam click dreapta 

pe "References", "Add reference", "projects" 
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Selectam ClassLibrary1 si dam OK. Puem pe Console Application1 set as startup 

Inlocuim codul din ConsoleApplication1, Program cu urmatorul:  

using System; 

using System.Collections.Generic; 

using System.Linq; 

using System.Text; 

using System.Data; 

using System.Data.SqlClient; 

namespace ConsoleApplication1 

{ 

    class Program 

    { 

        static void Main(string[] args) 

        { 

            try 

            { 
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                ClassLibrary1.Class1 p = new ClassLibrary1.Class1(); 

                string text = p.MessageFromBD(); 

                Console.WriteLine("found " + text);  

            } 

            catch (SqlException ex) 

            { 

                Console.WriteLine(" Eroare conexiune:" + ex.Message); 

                return; 

            } 

 

 

        } 

    } 

} 

 

CTRL+F5,ca sa vedem rezultatul. Daca merge, haidem sa il modificam si pe cel de Windows Forms( nu 

uitati sa puneti referinta si set as startup)  

 

Bun - acum vom face si o aplicatie WPF -click dreapta pe solutie, Add=>New Application, WpfApplication. 

Adaugati referinta la ClassLibrary1, adaugati acelasi cod ca la Windows Forms si CTRL+F5 

 

Ultimul pas, facem o aplicatie Web pentru aceasta aplicatie:  

In carte=>testBD creeam un folder numit WebApplication1.Apasam "Start=>Run , control panel( swtich to 

classic view daca scrie asa ceva), administrative tools, Internet Information Services" 

Expandati  "local computer ", "WebSites","Default Web Site", click dreapta pe "default web site",new , 

"Virtual directory" 
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La alias scrieti "WebApplication1" si la Directory scrieti calea catre folder ( la mine, 

C:\carte\testBD\WebApplication1) 

Asigurati-va ca la click dreapta pe "WebApplication1" , properties, ASP.NET, versiunea este 2.0 



Andrei Ignat Tutorial .NET 3.5   http://serviciipeweb.ro/iafblog/ 

http://serviciipeweb.ro/iafblog/ Tutorial .NET 3.5   Pagina 23 

 

 

 

Bun - acum sa creeam aplicatia. Pornim Microsoft Visual Web Developer 2008 Express Edition si 

"File=>OpenWebSite, Local IIS" si expandati pina dati de WebApplication1 
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Acum adaugam dll-ul care facea comunicarea cu BD: 

 

File=> Add=> Existing project si navigati pina la ClassLibrary1( la mine, C:\carte\testBD\ClassLibrary1). 

Adaugati csproj.Adaugam referinta la dll: La fel, click dreapta pe http://localhost/WebApplication1 , add 
reference, projects, classlibrary1  

Acum adaugam pagina unde o sa vedem mesajul : 

click dreapta pe http://localhost/WebApplication1 , add new item,  Web Form ( fiti atent in ce limbak dati -

C# sau VB.NET...) 

Acum, gasiti jos Design - apasati pe el 
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Din toolbox alegeti din nou butonul , trageti pe forma si dati dublu click 

Vom pune (aproape) acelasi cod ca si pentru WindowsForms/Console/WPF: 

protected void Button1_Click(object sender, EventArgs e) 

    { 

        try 

        { 

            ClassLibrary1.Class1 p = new ClassLibrary1.Class1(); 

            string text = p.MessageFromBD(); 

            Response.Write("found " + text); 

        } 

        catch (SqlException ex) 

        { 
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            Response.Write(" Eroare conexiune:" + ex.Message); 

            return; 

        } 

    } 

 

Apasati CTRL+F5, apasati pe buton si ar trebui sa va scrie: 

"Eroare conexiune:Cannot open database "testAndrei" requested by the login. The login failed. 

Login failed for user 'TEST1\ASPNET'. " 

Mai tineti minte ca am folosit conexiunea trusted : 

sc.ConnectionString = 

@"Server=.\SqlExpress;Database=testAndrei;Trusted_Connection=True;"; 

 

Acum, haideti sa ne identificam cum trebuie si in ASP.NET. click dreapta pe 

http://localhost/WebApplication1 , add new item,Web Configuration File(lasati numele de Web.Config asa 
cum este!), gasiti authentication  si puneti linga: 

<identity impersonate="true"/> 

CTRL+F5 din nou si acum apare: 

Eroare conexiune:Cannot open database "testAndrei" requested by the login. The login failed. 

Login failed for user 'TEST1\IUSR_TEST1'.  

Tare, nu ? Am schimbat un user cu altul - din ASPNET, sub care ruleaza ASP.NET, am schimbat 
IUSR_TEST1 - sub care rulam default. 

Hai sa facem ultima schimbare , ca sa ne recunoasca IIS : 

Apasam "Start=>Run , control panel( switch to classic view daca scrie asa ceva), administrative tools, 
Internet Information Services" 

Click dreapta pe "WebApplication1" , properties, Directory security, Anonymous access, Edit,scoateti 

"Anonymous Access" 
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OK si iar OK. Ne intoarcem la aplicatie si...Ura!, merge: 
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Observatii: 

1. Daca, in loc sa utilizam conexiunea „trusted”( Trusted_Connection=True )  foloseam una 

in care sa avem credentiale de SQLServer( de ex., sa cu ce parola ati dat) nu ne mai loveam 
de impersonare.. 

 
2. Acest lucru ne-a facut atenti si la aplicatia Windows Forms – e clar ca ea se bazeaza tare pe 

faptul ca suntem utilizatori „preferentiali” – cu drepturi de administrator – pentru SQL Server 
 

3. Puteti downloada proiectele de la adresa 
http://serviciipeweb.ro/iafblog/content/binary/net35/small/small.zip si 

http://serviciipeweb.ro/iafblog/content/binary/net35//small/smallBD.zip 
 

 
 
Tema pentru acasa : realizati aceeasi aplicatie in Silverlight (Hint :In Asp.NET, pe proiect,dati 
click dreapta, add new File=>Silverlight application)  

 

Lecturi Recomandate: 

http://serviciipeweb.ro/iafblog/content/binary/net35/small/small.zip
http://serviciipeweb.ro/iafblog/content/binary/net35/small/smallBD.zip
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 How to implement impersonation in an ASP.NET application, 
http://support.microsoft.com/default.aspx/kb/306158 

  

  

  

 

DESCRIERE A APLICATI EI  

Aplicatia pe care m-am gindit sa o facem va realiza urmatoarele:  

 Va tine o evidenta (paralela !) a angajatilor dintr-o firma ( va fi integrat Active Directory si va tine 

datele intr-o baza de date Sql Server 2008) 

 Va tine o evidenta a conturilor acestora pe diverse aplicatii, precum si a diferitelor beneficii ale 

user-ilor ( telefon, laptop, etc) 

 Va face un workflow pentru un nou angajat, astfel incit sa se stie sigur cine ce are de facut( 

cumparat birou, laptop, etc) 

 Pentru toate aceste actiuni se va tine o evidenta a celor care adauga/modifica date in sistem.  

 Pe masura ce vom dezvolta aplicatia, ii vom adauga tot felul de noi functionalitati.Sa o numim 

Evidan(de la Evidenta Angajati) 

 

Sa definim principalele roluri de actiune asupra sistemului:  

1. Administrator – are „puterea” de a „sterge” un angajat daca acesta nu a avut atribute, precum si 
de a defini atributele Workflow-ului si ale angajatului / aplicatiilor. 

2. Responsabil : indeplineste un anumit punct al workflow-ului pentru un nou angajat( ii da telefon, 
laptop, birou, il introduce in Active Directory, creeaza un email )  

3. HelpDesk – introduce / sterge atributele user-ului 
4. Raportare –are dreptul sa extraga un raport de pe site  

 

Cerintele de lucru pentru versiunea 1 : 

1. Definirea workflow-ului si administrarea acestuia 

2. Importul angajatilor din Active Directory  

3. Trecerea unui angajat nou prin workflow 

4. Trecerea unui angajat care pleaca prin workflow 

5. Vizualizarea etapelor workflow-ului pentru angajat 

6. Vizualizarea resurselor care tin de un angajat. 

http://support.microsoft.com/default.aspx/kb/306158
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Sunt deschis la sugestii pentru orice imbunatatire 

 

CREEA REA  BAZEI DE  DATE  –  SI FILEST REA M IN  S QL  SE RVER 2008  

Deocamdata o sa facem doar operatiile de CRUD pentru detaliile/resursele care tin de un Angajat . Hai sa 

enumeram citeva : 

1. Un Angajat are nume( se poate schimba – prin casatorie, de ex.), prenume , poza – sa le numim proprietati 

UserRelated 

2. Un Angajat poate avea telefon , laptop – sa le numim proprietati JobRelated 

3. Un Angajat poate avea cont de Active Directory, email , Citrix , acces VPN  - sa le numim ITRelated  

 

Evident ca am putea creea o tabela prin care sa avem , ca si coloane, toate aceste proprietati  - dar aplicatia nu ar fi 

destul de flexibila, in cazul in care cineva ar vrea sa mai adauge un detaliu/resursa ar trebui sa refacem aplicatia. 

Asa incit totul se rezolva cu un nivel de indirectare – o sa creez o tabela care sa contina gruparile de Proprietati 

(UserRelated, JobRelated , ITRelated) –, una  care sa contina Proprietatile( nume, prenume, poza, 

telefon, laptop, email, etc) si una care sa faca legatura intre ele. De asemenea , trebuie ca tabelele sa contina date 

despre cine a introdus informatia si pina cind e valabila – acestea vor fi 3 cimpuri, continute tot timpul in (aproape) 

fiecare tabela , de tipul :   

[DateModified<NumeTabela>] [datetime] NULL, --data modificarii 
 [NameUserModified<NumeTabela>] [nvarchar](150) NULL, - nume utilizator care a 
modificat 

 [IPModified<NumeTabela>] [nvarchar](150) NULL, -- ip-ul de la care s-a produs 

modificarea 

 

Deocamdata am ajuns la urmatoarea structura : 
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Pentru conformitate , iata scriptul de creere al tabelelor si scriptul de creerea a resurselor/detaliilor Angajatului.  

Ce vreau sa fac in continuare este sa fac coloana ValueBinaryUserGroupProperty de tipul FileStream 

– adica sa isi pastreze datele pe hard, de fapt. 

Verificam ca serverul suporta filestream – click dreapta pe server, “properties”, 

selectati “Advanced” si verificati ca filestream este OK: 
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Apoi click dreapta pe baza de date, “properties”, selectati FileGroups si acolo 

adaugati un filestream(bifati si “default”) 
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Acum trebuie sa adaugam un file ca sa putem profita de acest filestream . Trebuie 

ales File_Type : “filestream data”, filegroup-ul si, cel mai important, folder-ul in 

care sa il punem (ca alegere usoara, este acelasi folder ca fisierul primar de date) 
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Acum putem sa construim tabela noastra cu filestream – stergem tabela 

accUserGroupProperty (drop table accUserGroupProperty ) si o creeam cu suport de 

FileStream : 

CREATE TABLE [dbo].[accUserGroupProperty]( 
 [IDUserGroupProperty] [uniqueidentifier] NOT NULL ROWGUIDCOL PRIMARY KEY, 
 ToDateUserGroupProperty datetime NULL, 
 [ValueTextUserGroupProperty] [nvarchar](max) NULL, 
 [ValueBinaryUserGroupProperty] [varbinary](max) FileStream NULL, 
 [IDUser] [bigint] NOT NULL, 
 [IDProperty] [bigint] NOT NULL, 
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 [DateModifiedUserGroupProperty] [datetime] NULL, 
 [NameUserModifiedUserGroupProperty] [nvarchar](150) NULL, 
 [IPModifiedUserGroupProperty] [nvarchar](150) NULL, 
  
  

) 

Ce ne trebuie neaparat pentru o coloana de tipul FileStream : 

1. Suport Server, BD ( facut deja) 

2. O coloana in tabela respectiva de tipul NOT NULL ROWGUIDCOL PRIMARY KEY 

 

Cu ce ne afecteaza : cu aproape nimic – dar e bine sa poti vedea fisierele pe hard  * de ex., poza angajatului o 

sa fie direct pe hard in loc sa o stocam in BD. 

Nu uitati ca tot ce am facut aici prin click-uri se poate face si prin script, cu ajutorul butonului “Script” – se 

poate gasi usor in toate pozele precedente 

Tema pentru acasa : Creeati o baza de date cu support filestream, o tabela cu o coloana filestream 

si inserati un text. Observati modificarile de pe folder-ul unde ati spus sa se creeze FileStream. 

Lecturi Recomandate: 

FileStream cu SQL Server pe scurt  

http://blogs.microsoft.co.il/blogs/bursteg/archive/2008/05/09/sql-server-2008-filestream-part-1.aspx 

 

CREEA REA  RAPI DA A SIT E-ULUI S I A  APLICA TIEI  WEB DE A DM IN  

Vrem acum sa creeam partea de administrare. Vom folosi Linq2SQL si Dynamic Data. Mai intii creeam un DLL 

pentru DAL  . Porniti Visual Web Developer ( nu folositi Microsoft Visual C# 2008 Express Edition  - nu stie sa se 

conecteze la SQL Servere existente – ci doar sa creeze o BD SQL SERVER sau sa se conecteze la Sql Compact sau 

Access – pe cind WebDeveloper stie – nu ma intrebati pe mine de ce ...marketing, probabil...) 

Selectati „File=>New Project”, Alegeti „Class Library” si o numim DevinDLL (solutia o numim Devin ).Stergem 

nemilos class1 pe care a generat-o. Selectam „Project=> Add New Item”, alegem „Linq to Sql Classes”  si ne apare o 

pagina goala care ne imbie sa dam click pe „Database Explorer”. Asa si facem – si focusul se duce pe „Database 

Explorer”. Acolo dam click dreapta pe „Data Connections” , alegem in Data Source „Microsoft SQL Server (Sql 

Client)” ( daca nu apare , dati click pe „Change”) si introducem detaliile de conectare (Atentie : la server name 

punem numele Instantei – pentru o editie de Express este de obicei (local)\sqlexpress   - si selectati corect baza de 

date de la „Select or enter a database name” ). Dupa ce ati terminat, dati „Test Connection” si ar trebui sa fie OK ( 

daca nu, vedeti ce scrie in mesajul de eroare  - si scrieti-mi un email).  

http://blogs.microsoft.co.il/blogs/bursteg/archive/2008/05/09/sql-server-2008-filestream-part-1.aspx
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Acum vom trage tabelele din DB si vom compila(CTRL+SHIFT+B). Daca totul a mers bine, revenim la Solution 

Explorer, click dreapta pe solutie, „add=>new project”, selectam „Dynamic Data Web Application” si o numim 

DevinWeb. Adaugam la proiectul Webn ca referinta dll-ul (click dreapta pe „references”, tab-ul projects si selectam 

DevinDLL. 

Acum trebuie sa ii spunem proiectului Web ca isi poate lua datele din Linq2Sql din DLL. In global.asax cautati 

model.RegisterContext(typeof(YourDataContextType), new ContextConfiguration() 

{ ScaffoldAllTables = false }); 

Si inlocuiti cu  

model.RegisterContext(typeof(DevinDLL.DevinDataContext), new 

ContextConfiguration() { ScaffoldAllTables = true });  

Incercam sa compilam si –surprize, surprize ! –eroare: 
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error CS0012: The type 'System.Data.Linq.DataContext' is defined in an assembly that is not 

referenced. You must add a reference to assembly 'System.Data.Linq, Version=3.5.0.0, 

Culture=neutral, PublicKeyToken=b77a5c561934e089'.  

Pai – asta si facem – adaugam la references, tab-ul .NET , System.Data.Linq 

Compilam din nou –si OK! 

Dam F5 sa vedem site-ul( si raspundem cu Yes la „Modify the Web.config file to enable debugging) 

  

) 

Daca ati pus „scaffold all tables” la true, atunci deja vedeti tabelele: 
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 Va puteti juca acum dind click , editind, stergind – e un site functional. 

Ce as vrea sa imbunatatesc : 

1. Nu as vrea sa scrie „Dynamic Data Site” 

2. As vrea sa fie nu in radacina aplicatiei web, ci intr-un folder de admin 

Pentru 1 este simplu : Ma duc in Site.master, si inlocuiesc Dynamic Data Site cu „Employees admin site” 

Pentru a 2-a , e un pic mai complicat: inchidem creez un folder admin in C:\book35 si trag in el fisierele pentru 

Dynamic Data( folder-ul Dynamic Data + default.aspx). Deschidem web developer, click dreapta pe folder-ul din 

radacina „Dynamic data”, „Exclude from Project” . Acum apasam „Project=>Show all files” si includem in proiect 

folder-ul admin. 
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Acum trebuie sa ii spunem si aplicatiei ca am schimbat folder-ul unde este Dynamic Data. Intrati din nou in 

Global.asax si cautati routes.Add(new DynamicDataRoute ("{table}/{action}.aspx") 

Vom inlocui cu 

routes.Add(new DynamicDataRoute("admin/{table}/{action}.aspx") 

si ii spunem model-ului unde sunt fisierele: 

model.DynamicDataFolderVirtualPath="~/Admin/DynamicData"; 

De asemenea, mai avem de inlocuit toate paginile care folosesc Gridviewpager 

si Filterusercontrol (CTRL+SHIF+F, cautam gridviewpager si inlocuim 

src="~/DynamicData/Content/GridViewPager.ascx" 

cu  

src="~/admin/DynamicData/Content/GridViewPager.ascx" 

 

(paginile de modificat sunt List.aspx, ListDetails.aspx) 

La fel in List.aspx avem de inlocuit 

src="~/DynamicData/Content/Images/plus.gif" 

cu 

src="~/admin/DynamicData/Content/Images/plus.gif" 

La fel in site.master avem de inlocuit 

src="DynamicData/Content/Images/back.gif" 

cu 

src="~/admin/DynamicData/Content/Images/back.gif" 

Click dreapta pe „default.aspx”, „set as start page”-CTRL+F5 - si ar trebui sa fie ca la inceput. 

Data viitoare vom vorbi despre Linq2SQL si cum facem modificari in el. 

Pentru usurinta, gasiti sursele la 

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/sources1/devin1.zip si backup BD la 

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/sources1/devinx1.zip 

 

(apropo :  daca v-ati inregistrat la MS copia de Web Developer Express si va duceti la 

https://connect.microsoft.com/downloads/downloads.aspx?SiteID=40 – o sa gasiti acolo alte 3 carti  

http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/sources1/devin1.zip
http://serviciipeweb.ro/iafblog/content/binary/net35/instalare/sources1/devinx1.zip
https://connect.microsoft.com/downloads/downloads.aspx?SiteID=40
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Microsoft Visual C# 2005 Express Edition - Build a Program Now,  Microsoft Visual Web Developer 2005 Express 

Edition - Build a Web Site Now, Developing Desktop Applications with SQL Server Express Edition , SQL Server 

Express Edition eBook si 2 colectii de imagini :  Corbis Images  si IconBuffet Studio Suite –si inca citeva soft-uri.) 

Tema pentru acasa : 

 Modificati Dynamic Data web site astfel incit sa nu mai scrie « My tables » , ci « Devin Tables » 

Modificati Dynamic Data astfel incit sa tabelele sa nu mai apara cu prefixul acc(NU le modificati din 

DB, ci din Web site/Linq)  

 

Lecturi Recomandate: 

Dynamic data customization , http://mattberseth.com/blog/dynamic_data/ 

 

http://mattberseth.com/blog/dynamic_data/
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GL OSAR 

DAL : Data Access Layer 

DB, BD: Database 


	Ce vrem sa facem
	Primul pas : instalarea software-ului free
	Verificare instalare
	Aplicatii mici de test
	Descrierea aplicatiei
	Creearea Bazei de DATE – si FILESTREAM in SQL ServeR 2008
	CREEAREA RAPIDA A SITE-ULUI SI A APLICATIEI WEB DE ADMIN
	GLOSAR

